Düşeyara Fonksiyonu ve Parametrelerinin Kullanımı



Düşeyara Fonksiyonu Nedir ?

Düşeyara fonksiyonunun ne olduğundan ve temel anlamında temel düzeyde nasıl kullanıldığından  Ms. Excel ' de DüşeyAra Formülü makalemizde bahsetmiştik . 
Bu makalemizde ise Arama ve Başvuru fonksiyonlarından düşey ara fonksiyonunu örnekle açıklamaya çalışacağım .

Örnek Tablomuz 



Bu tabloya göre elimizde kişiler ve bu kişilerin doğum yeri bilgileri var . Küçük bir tabloda belki aradığımızı kolayca bulabiliriz ama veriler arttıkça aradığımızı bulmamız zorlaşır .
Örneğin biz Sicil Nosu yazılan kişinin adı ve soyadının otomatik gelmesini istiyoruz .  Ve sicil nosu alanına 114 yazalım .

Bunun için yazmamız gereken formül  
=DÜŞEYARA(F2;A2:C9;2;0)
Şeklinde olmalıdır . 



Ve ENTER tuşuna bastığımızda 114 ' ün bulunduğu satırdaki Ad Soyad otomatik olarak gelecektir . 



=DÜŞEYARA(F2;A2:C9;2;0)
Formülümüzde gördüğümüz gibi bizim 4 adet parametremiz vardır .


  • İlk parametremiz F2 yazan aranan_değer alanıdır . Bu parametreye neyi aramak istiyorsak onu yazıyoruz .
  • İkinci parametremiz A2:C9 yazdığımız tablo_dizisi parametresidir . Aradığımız veriyi hangi tablo aralığında arayacağımızı belirliyoruz .

    Tüm tabloyu seçebiliriz . Ama çok fazla sütunun olduğu bir tablo ise belirli kısmını da seçebiliriz .
  • Üçüncü parametremiz ise 2 yazdığımız sütun indis sayısıdır . Yani tablomuzun kaçıncı sütununda arama yapılacaktır .

    Her zaman arama yapılacak değer ilk sütunda olmalıdır . İlk sütundaki aranan değer bulununca o satır tamamen seçilir ve seçili alandaki hangi bilgiyi istediğimiz bu parametremiz sayesinde belirlenir.
  • Ve son olarak dördüncü parametremiz ise 0 ( sıfır ) olan sayesinde ise aradığımın verinin birebir aynısını istediğimi belirtiyorum .

    Bu alana 0 ( sıfır ) ya da Yanlış yazabilirim . İkisi de aynı anlamdadır .

Yukarıda Ms. Excel çalışma ekranında da bunu görebiliriz .

Peki Yanlış tam eşleme demektir . Kullanımından bahsettik . Peki ya Doğru nedir ? Ne zaman kullanılır ? 

Doğru kullanımını da farklı bir örnekle açıklayalım .

Örnek Tablomuz



Bu tablomuz düşeyara formülümüzün 4. paremetresini Doğru olacak kullancağımız örnek tablomuz olsun . 

Normalde bu tablonun sonuç alanı için içiçe eğer formülünü kullanarak uygun formülünü oluşturabiliriz. 

Ama bu uzun bir formül . Biz düşeyara formülünü kullanarak bu işlemi deneyeceğiz. 

Öncelikle Notlar alanını dolduralım .


Benim notlar alanına 50 ve 60 yazma nedenim arada bir değer olursa nasıl hareket edebileceğimizi görmemizi sağlamaktır . 


Formülümüz yazılır ve Enter tuşuna basılarak sonuç görülür . 

=DÜŞEYARA(A2;F2:G6;2;DOĞRU)

Formülümüz yukarıdaki şekilde yazılır . Aynı şekilde 4 parametreden oluşur .

  • İlk parametremiz A2 yazan aranan_değer alanıdır . Bu parametreye neyi aramak istiyorsak onu yazıyoruz .
  • İkinci parametremiz F2:G6 yazdığımız tablo_dizisi parametresidir . Aradığımız veriyi hangi tablo aralığında arayacağımızı belirliyoruz .

    Tüm tabloyu seçebiliriz . Ama çok fazla sütunun olduğu bir tablo ise belirli kısmını da seçebiliriz .
  • Üçüncü parametremiz ise yazdığımız sütun indis sayısıdır . Yani tablomuzun kaçıncı sütununda arama yapılacaktır .

    Her zaman arama yapılacak değer ilk sütunda olmalıdır . İlk sütundaki aranan değer bulununca o satır tamamen seçilir ve seçili alandaki hangi bilgiyi istediğimiz bu parametremiz sayesinde belirlenir.
  • Ve son olarak dördüncü parametremiz ise bir ( 1 ) olan sayesinde ise aradığımın verinin birebir aynısını istediğimi belirtiyorum .

    Bu alana 1 ( bir ) ya da Doğru yazabilirim . İkisi de aynı anlamdadır . Ben örnekte Doğru yazdım .


Lakin bu formülde Ms. Excel ' deki diğer formüller gibi sürükleme yapılmaz. Üstteki örnek resimde sürükleme yapıldığı takdirde 2. parametrede seçilmiş olan tablonun da hücre aralığının değiştiğini görüyoruz . Tablo aralığının sabit kalması , değişmemesi gerekir ki sonuç doğru çıksın. Sürükleme yapmadan önce hücre sabitlemek gerekir . 

Hücre sabitleme 2 şekilde yapılabilir . 
  1. İlk yöntemimiz formülde sabitleme yapılacak hücrenin adına tıklayıp , ardından klavyeden F4 tuşuna basmaktır .
  2.  Diğer yöntem ise sütun adının ve satır adının başına $ işareti koymak olacaktır .


Not :  Düşeyara formülünde " Doğru " ya da " 1 " parametresini kullanabilmek için aranılan değerlerin sıralı olması gerekir . Bizim tablomuza göre bakacak olursak F sütunundaki notların sıralı olması gerekiyor . 0 ( sıfır ) dan başlayarak artarak devam etmiş .