Ms. Excel

Ms. Excel Ders Notları – Excel ‘de Formüller

excel-2016

Ms. Excel Ders Notları – Excel ‘de Formüller

FORMÜLLERDE KULLANILAN BAZI İŞLEVLER

İşlev, formül yazımını kolaylaştırmayı sağlayan komutlara verilen genel isimdir. Excel çeşitli alanlara yönelik çok sayıda işlev vardır. Bunların Listesine EKLE menüsündeki İşlev seçeneğiyle ulaşılabilir. Excel en çok işe yarayan işlevlerin bazıları aşağıda gösterilmiştir;
   TOPLA İŞLEVİ      : Belirtilen Hücre aralığında bulunan hücrelerdeki sayıları toplamayı sağlar.
               
  Genel Kullanımı:   =TOPLA(İlk Hücre:Son Hücre)
                                       ORTALAMA İŞLEVİ           : Belirtilen Hücre aralığında bulunan sayıların aritmetik ortalamasını alamayı sağlar
Genel Kullanımı :      =ORTALAMA(İlk Hücre:Son Hücre)
                                       MAK İŞLEVİ          : Belirtilen Hücre aralığında bulunan sayılardan En Büyük Olanı bulmayı sağlar
Genel Kullanımı :      =MAK(İlk Hücre:Son Hücre)
                                       MİN İŞLEVİ            : Belirtilen Hücre aralığında bulunan sayılardan En Küçük Olanı bulmayı sağlar
Genel Kullanımı :      =MİN(İlk Hücre:Son Hücre)
                                       ÇARPIM İŞLEVİ    : Belirtilen Hücre aralığında bulunan sayıları çarpmayı sağlar
Genel Kullanımı :      =ÇARPIM(İlk Hücre:Son Hücre)
                                      YUVARLA İŞLEVİ  : Ondalıklı sayıların yuvarlatılmasını sağlar.
Genel Kullanımı :   =YUVARLA(Ondalıklı sayı;Ondalık Hane Sayısı)
 
 
 
 EĞER İŞLEVİ        : Kullanıcının belirttiği şarta bağlı olarak hangi işlemin yapılacağını belirler. Şart Doğruysa işlem1 değilse işlem2 yapılır. Formül (işlem) yerine metin yazılacaksa “ işareti içinde yazılmalıdır.
  Genel Kullanımı :   =EĞER(Şart;İşlem1;İşlem2)
 
 
 
 
 

Formül örnekleri:

§ =A3*15 ………………..A3 hücresindeki sayı ile 15 in çarpımı )
§ =a3-b2…………………..a3 hücresindeki sayıdan b2 hücresindeki sayıyı çıkar.
§ =22/a3…………………..22 ile a3 hücresindeki sayıyı böl
§ =(a2+b2+c2)/3…………a2,b2 ve c2 hücresindeki sayıları topla 3 e böl.
§ =TOPLA(A2:A10)……..a2 ve a10 dahil iki hücre arasındaki sayıları toplar.
§ =topla(a2;a10)……..…..sadece a2 ve a10 hücrelerini toplar.
§ =Ortalama(a5:b5)………a5 ile b5 hücresi arasındaki sayıların ortalamasını alır
§ =yuvarla((14,5369);3)…parantez içindeki ondalık sayının virgülden sonraki üç basamağını yuvarlar.böylece sonuç 14,5 olur…
 
 
§ =min(a3:a9)……………a3 ile a9 hücresi arasındaki sayılardan en küçüğünü verir.
§ =mak(a3:a9)…………….a3 ile a9 hücresi arasındaki sayılardan en büyüğünü verir.
§ =eğer(d3>45;”geçti”;”kaldı”)…eğer d3 hücresindeki sayı 45 ten büyükse “geçti” şayet değilse
“kaldı”yazar.
§ =eğer(d3>=45;”geçti”;”kaldı”)…eğer d3 hücresindeki sayı 45 e eşit veya 45 ten büyükse “geçti”
şayet değilse “kaldı” yazar.
Yukarıda yazdıklarım en çok kullanılan formül kalıplarıdır. Bir sonraki yazımda örneklerle işleyeceğiz.

 

Excel’in formüllerdeki işlemleri yapma sırası

Bazı durumlarda hesaplamanın gerçekleştirildiği sıra, formülün hesapladığı değeri etkileyebilir; dolayısıyla istediğiniz sonucu elde etmek için sıranın nasıl saptandığını anlamak ve sıranın nasıl değiştirilebileceğini bilmek önemlidir.
  • Hesaplama sırası
    Formüller verileri özel bir sırada hesaplar. Excel’de bir formül her zaman eşittir işaretiyle (=) başlar. Excel, eşittir işaretini izleyen karakterleri formül olarak yorumlar. Eşittir işaretinden sonra sabit veya hücre başvurusu gibi hesaplanacak öğeler (işlenen) gelir. Bunlar hesaplama işleçleri tarafından ayrılmıştır. Excel, formülleri formüldeki her işlecin özel sırasına göre soldan sağa doğru hesaplar.
 
  • Excel formüllerindeki işleçlerin önceliği
    Birden fazla işleci tek bir formülde birleştirirseniz, Excel, işlemleri aşağıdaki tabloda gösterilen sırayla yapar. Bir formül, aynı önceliğe sahip olan işleçler içeriyorsa, (örneğin, bir formül, hem bir çarpma işleci, hem de bir bölme işleci içeriyorsa), Excel, işleçleri soldan sağa doğru değerlendirir.
 
İşleç
Açıklama
: (iki nokta üst üste)
  (tek boşluk)
, (virgül)
Başvuru işleçleri
Olumsuzlama (-1’deki gibi)
%
Yüzde
^
Üs
* ve /
Çarpma ve bölme
+ ve –
Toplama ve çıkarma
ve
İki metin dizesini köprüler (art arda bağlama)
=
< >
<=
>=
<> 
Karşılaştırma

 

Yorum Yapın

Benzer İçerikler

Daha Fazla İçerik